Differences between revisions 15 and 16
Revision 15 as of 2008-08-16 15:57:18
Size: 9269
Editor: ?empika
Comment:
Revision 16 as of 2008-08-18 14:10:11
Size: 9417
Editor: ?IvanSanchez
Comment:
Deletions are marked like this. Additions are marked like this.
Line 28: Line 28:
 * Internal microphone does not seem to work.
 * Only three of the four "silver" keys (in the silver strip where the power button is) throw an ACPI event. The hotkey.sh script should reference those keys to do something useful (e.g. toggle webcam/bluetooth on/off).
 * Internal microphone does not seem to work. Most probably the 901 suffers from theh same problem as the 900. See http://wiki.debian.org/DebianEeePC/Model/900#head-1ef9e12308f2364008cb9f9871633d94ea331159 .
 * The four "silver" keys (in the silver strip where the power button is) throw an ACPI event. The hotkey.sh script should reference those keys to do something useful (e.g. toggle webcam/bluetooth on/off).

Work on supporting the 901 and other Atom-based models (1000, 1000H) has commenced. We have a source package for the atl1e ethernet driver at http://eeepc.debian.net/ and are working on producing debs of this and rebuilding the installer to include them so that an ethernet-based install on these models will be possible.

A driver for the wireless hardware can be found at http://www.ralinktech.com.tw/data/drivers/2008_0708_RT2860_Linux_STA_v1.7.0.0.tar.bz2.

?JohnGoerzen has confirmed these things work on the 901:

  • X
  • Hardware ethernet
  • Wifi with above driver, including WPA2 and network-manager
  • Suspend/Resume
  • Hotkeys: suspend, brightness, others untested.

Performance seems to be better than the Xandros install.

?ThijmenDeGooijer has confirmed these things to work on the 1000H:

  • X also on external display
  • Hardware ethernet
  • Wifi with above driver, including WPA2 and network-manager
  • Sound output, recording untested
  • Suspend/Resume to disk
  • Hotkeys: suspend, brightness, volume control (after modifying VOLUME_LABEL in /etc/default/eeepc-acpi-scripts).

?IvanSanchez reports:

  • In order for the Wifi hotkey (Fn+F2) to work, /etc/acpi/actions/wireless.sh needs to be tweaked - replace "ath0" with "ra0" and "ath_pci" with "rt2860sta". Do this after installing the rt2860sta driver from the above link.
  • Bluetooth works OK, but only if enabled from the BIOS. There is no way (yet) of enabling/disabling it - the eeepc acpi module needs some patching (see http://forum.eeeuser.com/viewtopic.php?pid=304343). The bluetooth adapter is an USB device, much like the webcam.

  • Remember to install cpufreq-utils to allow throttling, if you skipped tasksel (works like a charm with acpi_cpufreq).
  • ACPI events do work out of the box with 2.6.26 kernel - seems like the 901's ACPI implementation is less buggy than the 701's.
  • rt2860sta driver won't compile with 2.6.26 kernel (sid); use 2.6.25 (lenny) for the time being.
  • Internal microphone does not seem to work. Most probably the 901 suffers from theh same problem as the 900. See http://wiki.debian.org/DebianEeePC/Model/900#head-1ef9e12308f2364008cb9f9871633d94ea331159 .

  • The four "silver" keys (in the silver strip where the power button is) throw an ACPI event. The hotkey.sh script should reference those keys to do something useful (e.g. toggle webcam/bluetooth on/off).
  • suspend/hibernate/resume works; X with external display works (hint: edit /etc/default/eeepc-acpi-scripts for a higher resolution); LAN works.

This doesn't seem to work out-of-the-box:

  • Display switching
  • Hotkeys: LCD off, others untested

Hints and Tips from empika

webcam

you need to

#apt-get install module-assistant

this should also install the kernel headers needed to build the wireless drive. next runn

#module-assistant auto-install linux-uvc

to install the right module for the webcam. afterwards run

#echo 1 > /proc/acpi/asus/camera

you should now have a working webcam, test it with Cheese :D

wifi

I followed the instructions on http://www.itwriting.com/blog/778-fixing-wi-fi-on-asus-eee-pc-901-with-linux.html which links to this driver from Ralink http://www.itwriting.com/DPO_RT28xx_60_LinuxSTA_V1.7.0.0_2008_07_15.tgz, it has special eee-pc bits in and is ready to compile once extracted, just run make and make install in the source dir.

You need to edit /etc/acpi/actions/wireless.sh and replace all instances of ath0 with ra0 and ath_pci with rt2860sta To get the wireless hotkey to display the correct message when on the OSD you need to edit /etc/acpi/actions/hotkey.sh, find the line (around 35)

if grep -q ath0 /proc/net/wireless; then

and change it to

if grep -q ra0 /proc/net/wireless; then

network-manager-gnome didnt work for me, it did not give me the option to use WPA encryption so I installed Wicd which works pretty well most of the time. grab it from http://wicd.sourceforge.net/

follow the instructions on the download page and remove everything from /etc/network/interfaces bar

auto lo
iface lo inet loopback

wikd should be in your apps->internet menu, you can now run it and connect to wireless AP's!

hotkeys, osd and misc bits

run apt-get install aosd-cat to install the OSD display'er. you then need to edit /etc/default/eee-acpi-scripts and change the following lines ENABLE_OSD='no' to ENABLE_OSD='yes' while were here, lets change {{{VOLUME_LABEL='?LineOut' VOLUME_LABEL='iSpeaker'}}} to {{{VOLUME_LABEL='Master' VOLUME_LABEL='Headphones'}}}

Multiple monitors

this is detailed on another page but i had some issues getting the desktop to display over the two monitors so have pasted my xorg.conf and some more info below to help. Firstly install xrandr if its not already

#apt-get install xrandr

then edit /etc/default/eee-acpi-scripts, change the line COMBINED_DISPLAY_SWITCHES='--mode 640x480' to

COMBINED_DISPLAY_SWITCHES='--output VGA --auto --above LVDS'

next you need to edit your /etc/X11/xorg.conf here is my version

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "gb"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "synaptics"
        Option          "CorePointer"
        Option          "SendCoreEvents"        "true"
        Option          "Device"        "/dev/input/mice"
        Option          "Protocol"      "auto-dev"
        Option          "HorizEdgeScroll"       "1"
EndSection

Section "Device"
        Identifier      "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
        Driver          "intel"
        BusID           "PCI:0:2:0"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
        Option          "DPMS"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
        Monitor         "Configured Monitor"
        DefaultDepth    24
        SubSection      "Display"
                Depth   24
                Modes   "1024x600"
                #ADD LINE FOR MULTI DISPLAYS
                #this is 1024 wide by 1368 high (768+600=1368)
                Virtual 1024 1368
        EndSubSection
EndSection

restart X without your external monitor plugged in, hitting the hotkey (f+f5) should now activate your external monitor. if not you can debug issues by running

#xrandr

as a normal user (or a user that has permission to run x stuff), this will give you an output from which you can tell which monitors are plugged in. without external monitor plugged in

Screen 0: minimum 320 x 200, current 1024 x 600, maximum 1024 x 1368
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x600+0+0 (normal left inverted right x axis y axis) 195mm x 113mm
   1024x600       60.0*+
   800x600        60.3
   640x480        59.9
TV disconnected (normal left inverted right x axis y axis)

with external monitor plugged in

Screen 0: minimum 320 x 200, current 1024 x 600, maximum 1024 x 1368
VGA connected (normal left inverted right x axis y axis)
   1024x768       60.0
   800x600        60.3
   640x480        59.9
LVDS connected 1024x600+0+0 (normal left inverted right x axis y axis) 195mm x 113mm
   1024x600       60.0*+
   800x600        60.3
   640x480        59.9
TV disconnected (normal left inverted right x axis y axis)

running the xrandr command with the options we specified in /etc/default/eee-acpi-scripts should also help you debug any problems

#xrandr --output VGA --auto --above LVDS

a few more annoying things that ive found with the default install

*Iceweasle has an odd version of flash installed where the flash movies are replaced by 'play buttons', this stops a few things working i found. i found this thread which helped sort the issue http://forums.debian.net/viewtopic.php?t=29837&postdays=0&postorder=asc&start=0, quit iceweasel if its running and remove the odd version of flash

#apt-get remove swfdec-mozilla
#aptitude keep-all

the apt-get remove will complain about removing gnome but this is aparently a pseudo package and it was safe for me to hit y. not sure what aptitude keep-all does but they suggest to run it so i did, nothing bad seemed to happen. Next grab the latest flash from adobe and install it to /usr/lib/iceweasel when asked. now restart iceweasel and flash should be working a treat.

The other thing that bugged me about iceweasel was that it doesnt have backspace set as go back in history as default. i like this and to get it working type about:config in the address bar, you will be warned about it being dangerous to mess with these options but we're brave right? use the filter to search for backspace, you should get 1 result back called browser.backspace_action, its value was set to 2, setting it to 0 will make it become a back key again.