This page briefly documents Debian on Asus Eee PC models 1001P, 1001PX, 1005P and 1005PE. These are 64-bit Atom netbooks using the Intel "Pine Trail" chipset. You can install either amd64 or i386 architecture.

Please don't use this page to track bugs. File bugs instead, tagging them with model-specific usertags as described on our About Bugs page, then link to Debian bug numbers in the Model tables as needed.

Installation

It is recommended to install Squeeze, as this contains up-to-date drivers for this model.

Alternatively, you may wish to install Lenny, but beware that you will not have a network during the install and need to upgrade your kernel using a kernel backport for that to work.

The old custom installer image described in our Install HowTo is not recommended, as it is a network-based installer and lacks drivers for this model.

Model-specific issues/status

To fix a problem with the wrong bus being used to hotplug ethernet/wifi, you will need to upgrade your BIOS, otherwise ethernet will not show up in lspci and no wifi access points will be visible. See the BIOS Upgrade HowTo for details.

Also, check the Model tables for any issues that apply to this/these model(s).

Some models (confirmed on 1001PX with 2.6.32-17 kernel) may require a workaround for sound to operate properly. One symptom is that while internal speakers work fine, plugging in headphones does not. To fix, you need to specify 'model=lifebook' when loading the snd-hda-intel module. To apply this workaround, close all sound-using applications and:

echo "options snd-hda-intel model=lifebook" >>/etc/modprobe.d/zz-local.conf
modprobe -r snd-hda-intel
modprobe snd-hda-intel

This solution was found in the Ubuntu bug for the issue: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/580183. FixMe: file Debian bug and cross-reference the Ubuntu bug.

Boot

Requires acpi_osi="!Windows 2009" or acpi_osi="Linux" else eeepc-laptop won't be loaded.

To make this change permanent, edit the GRUB_CMDLINE_LINUX option in /etc/default/grub as follows:

GRUB_CMDLINE_LINUX='acpi_osi="Linux"'

Then run:

update-grub

and reboot.

Be careful to specify quotes as shown. If you boot the installer with this option, it will be added incorrectly to /etc/default/grub as: GRUB_CMDLINE_LINUX="acpi_osi="Linux"" which you then need to fix as indicated above.

Hardware

Here is the content of /proc/cpuinfo and the output of dmesg and lspci: cpuinfo.txt, dmesg.txt, lspci.txt for a 1005PE model.

Hard Disk

My 1005P shipped with a 250GB Seagate mechanical HDD, containing some kind of Windows 7 installer (which broke), splashtop (sde3) and something for the BIOS (the "quick boot" thing?):