Compaq Evo N410c

9 Apr 05 I switched to ?UbuntuLinux about the time 4.10 was released, but tonight I finally spent the time to track down how to get wireless working. This documents the process: http://www.ubuntulinux.org/wiki/InstallingCompaqW200

That page didn't exist when I started using Ubuntu. If I ever meet the author, I'll buy him a beer. (Assuming he's of legal drinking age.)

<>< TimChambers

The following is old -- maybe even out of date.

http://larve.net/people/hugo/2002/12/evo410 has a lot of helpful hints.

TBD: see what applies from http://www.brokedown.net/~squash2/n600c.html


11Nov03 I mucked around with various permutations, including trying to build a custom kernel. I settled on running Sid. Woody is just too outdated to use as a base, IMO. I installed just fine from a boot CD and downloaded packages using the built-in LAN interface.

Wireless. You need at least the 2.4.20 kernel (says Dayne) to get the W200 wireless card working. I followed the instructions at http://orinoco-usb.alioth.debian.org/. I got it working, but as I write this the package appears to be broken. That's too bad, because at [http://hackingsociety.org/chapters/nclug/ Hacking Society] I even got my box configured to be a gateway for a box that didn't have wireless. I plugged them together with a crossover cable and routed for it. But that's not Evo-specific, so specifics are left as an exercise for the reader. (Actually, I simply don't remember how I did it beyond using iptables and masquerading. :-)

I wrote [http://ranty.pantax.net/pipermail/orinoco-usb-devel/2003-November/000368.html a note] to the [http://ranty.pantax.net/pipermail/orinoco-usb-devel/ orinoco-usb-devel] list. I'm keeping an eye on the ?SourceForge [http://sourceforge.net/mailarchive/forum.php?forum=orinoco-users orinoco-users] list, too.

User I/O. My USB mouse with scroll wheel works. Khalid says to use hotkeys to control the built-in keyboard buttons. Use xev to see what they do. I haven't tried this yet.

Desktop. I tried KDE. I liked it, but I got myself into a state where it wasn't working. I wanted to try Evolution anyway. (LESSON: don't mix KDE and GNOME apps -- use kmail with KDE and Evolution with GNOME.) So I'm happily using GNOME unstable now.

Sound. I had to figure out which sound systems to add. For KDE it's aRts and for GNOME it's esound. Now I'm happily listening to my !["MP3s"] with XMMS.

CD-RW. I'm using the HITACHI_["DK23DA"]-30. The secret is to use SCSI emulation. I followed instructions in /usr/share/doc/cdrecord/README.ATAPI.setup. http://www.rm-r.net/~meff/i8200/ also talks about using the HITACHI_["DK23DA"]. Use cdrecord (maybe obvious to you, but I had to learn about it by asking around).

<>< TimChambers