Differences between revisions 102 and 109 (spanning 7 versions)
Revision 102 as of 2018-11-28 14:33:46
Size: 14669
Editor: ?Alessio Garzi
Comment:
Revision 109 as of 2021-01-19 09:08:38
Size: 15951
Editor: ?YaoWei
Comment: Fix gcin and hime
Deletions are marked like this. Additions are marked like this.
Line 15: Line 15:
  * [[https://packages.debian.org/source/sid/gcin|gcin]]
  * [[https://packages.debian.org/source/sid/gmpc|gmpc]]
Line 22: Line 21:
  * [[https://packages.debian.org/source/sid/hime|hime]]
Line 29: Line 27:
  * [[https://packages.debian.org/source/sid/psensor|psensor]]
Line 32: Line 29:
  * [[https://packages.debian.org/source/sid/redshift|redshift]]
Line 76: Line 72:
=== Package: redshift ===

  * Who: Kentaro Hayashi <hayashi@clear-code.com>
  * Package (unstable): [[https://packages.debian.org/source/sid/redshift|redshift]]
  * Bug (Debian): [[https://bugs.debian.org/956779|#956779]]
  * Bug (Upstream): https://github.com/jonls/redshift/pull/757
Line 92: Line 94:

=== Package: gmpc ===

  * Who: Kentaro Hayashi
  * Patch exists: yes
  * Bug report: DebianBug:956768
  * [[https://packages.debian.org/source/sid/gmpc|gmpc]]
  * Comment: likely to be in next upload -smcv
Line 151: Line 161:

=== Package: psensor ===

  * Who: Ozzyboshi
  * Last change: 2019-02-4
  * Patch exists: yes
  * Patch-URL: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=921339
  * Upstream-Request:
  * Bug report: DebianBug:921339
  * Comment:
  * Fixed in version: -
  * Fixed upstream: -

== INDICATOR-SUPPORT-REMOVED: Packages that no longer use indicators and the their indicator dependencies and code have been removed during the course of this transition ==
Line 160: Line 184:
  * Comment: -1 This packages does not use indicators anymore, the newly submitted bug report requests the uploader to just remove the build dependency   * Comment: -1 This package does not use indicators anymore, the newly submitted bug report requests the uploader to just remove the build dependency
Line 212: Line 236:

=== Package: gcin ===
  * Who: mwei
  * Last change: 2021-01-19
  * Patch exists: yes
  * Patch-URL: https://salsa.debian.org/debian/gcin/-/blob/master/debian/patches/0013-Use-ayatana-indicator.patch
  * Bug report: DebianBug:956766
  * Fixed in version: 2.9.0+dfsg1-2
  * Fixed upstream: no
Line 258: Line 291:
=== Package: hime ===

  * Who: mwei
  * Last change: 2021-01-19
  * Patch exists: yes
  * Patch-URL: https://salsa.debian.org/debian/hime/-/blob/master/debian/patches/0003-Use-ayatana-indicator.patch
  * Bug report: DebianBug:956772
  * Fixed in version: 0.9.11+dfsg-2
  * Fixed upstream: no

Ubuntu Indicators to Ayatana Indicators Transition

Contents

  1. Ubuntu Indicators to Ayatana Indicators Transition
    1. Packages that require a Patch and are not yet being worked on
      1. Package in Debian with already enabled Indicator Support
      2. Packages in Ubuntu that have Indicator Support enabled, but not so in Debian
      3. Packages in Ubuntu main that need to be ported a.s.a.p.
    2. W-I-P: Packages that currently get patched
      1. Package: blueman
      2. Package: redshift
    3. POSTPONED: Packages with awkward status in Debian (unclear if we should patch them at all)
    4. SUBMITTED: Packages with patches sent out to package maintainers
      1. Package: deluge-gtk
      2. Package: gmpc
      3. Package: kupfer
      4. Package: lightdm-gtk-greeter
      5. Package: update-notifier (Ubuntu-only)
      6. Package: parcellite
      7. Package: clipit
      8. Package: psensor
    5. INDICATOR-SUPPORT-REMOVED: Packages that no longer use indicators and the their indicator dependencies and code have been removed during the course of this transition
      1. Package: gtimelog
    6. TO-BE-REMOVED: Packages that should be rather removed from Debian than patched
    7. ALREADY-REMOVED: Packages that have been removed from Debian during the course of this transition
      1. Package: libgtk2-appindicator-perl
    8. DONE: Packages that have been switched to Ayatana Indicators
      1. Package: appindicator3-sharp
      2. Package: budgie-indicator-applet
      3. Package: gajim-appindicatorintegration
      4. Package: gcin
      5. Package: gpodder
      6. Package: gnome-pie
      7. Package: gnome-shell-pomodoro
      8. Package: guake-indicator
      9. Package: hime
      10. Package: mate-indicator-applet
      11. Package: mate-polkit
      12. Package: network-manager-applet
      13. Package: onboard
      14. Package: pasystray
      15. Package: ring
      16. Package: transmission
      17. Package: ubiquity (Ubuntu-only)
      18. Package: variety
      19. Package: xfce4-indicator-plugin
      20. Package: remmina
      21. Package: telegram-desktop

Packages that require a Patch and are not yet being worked on

If interested in porting one the package from the below list to Ayatana Indicators, simply move the package name to the W-I-P section and create a status block for it.

Package in Debian with already enabled Indicator Support

Packages in Ubuntu that have Indicator Support enabled, but not so in Debian

  • brasero
  • glipper
  • gtk-recordmydesktop
  • kazam
  • linuxdcpp
  • quicksynergy
  • radiotray
  • uget
  • virt-manager

Packages in Ubuntu main that need to be ported a.s.a.p.

$ reverse-depends -c main src:libappindicator
Reverse-Depends
===============
* network-manager-gnome         (for libappindicator3-1)       -> SEE BELOW
* remmina                       (for libappindicator3-1)       -> SEE BELOW
* transmission-gtk              (for libappindicator3-1)       -> SEE BELOW
* ubiquity-frontend-gtk         (for gir1.2-appindicator3-0.1) -> SEE BELOW 
* update-notifier               (for libappindicator3-1)       -> SEE BELOW

All Ubuntu packages above have been handled already.

W-I-P: Packages that currently get patched

Package: blueman

  • Who: sunweaver
  • Package (unstable): blueman

Package: redshift

POSTPONED: Packages with awkward status in Debian (unclear if we should patch them at all)

SUBMITTED: Packages with patches sent out to package maintainers

Package: deluge-gtk

Package: gmpc

  • Who: Kentaro Hayashi
  • Patch exists: yes
  • Bug report: 956768

  • gmpc

  • Comment: likely to be in next upload -smcv

Package: kupfer

Package: lightdm-gtk-greeter

Package: update-notifier (Ubuntu-only)

Package: parcellite

Package: clipit

Package: psensor

INDICATOR-SUPPORT-REMOVED: Packages that no longer use indicators and the their indicator dependencies and code have been removed during the course of this transition

Package: gtimelog

  • Who: Ozzyboshi
  • Last change: 2018-11-29
  • Patch exists: no
  • Patch-URL:
  • Upstream-Request:
  • Bug report: 914895

  • Comment: -1 This package does not use indicators anymore, the newly submitted bug report requests the uploader to just remove the build dependency
  • Fixed in version: -
  • Fixed upstream: -

TO-BE-REMOVED: Packages that should be rather removed from Debian than patched

  • None known, at the moment.

ALREADY-REMOVED: Packages that have been removed from Debian during the course of this transition

Package: libgtk2-appindicator-perl

  • Who: jbicha, sunweaver
  • Last change: 2018-03-31
  • Removal Request: 894377

  • Other bug reports: 889108

  • Comment: Package has been removed from Debian

DONE: Packages that have been switched to Ayatana Indicators

Package: appindicator3-sharp

Package: budgie-indicator-applet

Package: gajim-appindicatorintegration

Package: gcin

Package: gpodder

Package: gnome-pie

Package: gnome-shell-pomodoro

Package: guake-indicator

  • Who: sunweaver
  • Last change: 2018-08-29
  • Bug report: 906046

  • Fixed in version: 1.4-1
  • Fixed upstream: yes

Package: hime

Package: mate-indicator-applet

Package: mate-polkit

Package: network-manager-applet

Package: onboard

Package: pasystray

Package: ring

Package: transmission

Package: ubiquity (Ubuntu-only)

Package: variety

Package: xfce4-indicator-plugin

Package: remmina

  • Who: mfv
  • Last change: 2017-10-30
  • Patch exists: yes (upstream)
  • Patch-URL:
  • Bug report: -
  • Comment: -
  • Fixed in version: 1.2.0-rcgit.24-2
  • Fixed upstream: yes

Package: telegram-desktop